It seems to be, you are running multiple PHP versions on your system.

Your webserver (this site) is running with version: 7.4.30
The defined command in "other/phpcommand.php" is running with version: 8.1.8

Please use the same PHP version for both!

You can define the version for the Ranksystem Bot inside the file "other/phpcommand.php". More information and examples you will find inside.
Current definition out of "other/phpcommand.php":
php
You can also change the PHP version, your webserver is using. Please use the world wide web to get help for this.

We recommend to use always the latest PHP version!

If you can't adjust the PHP versions on your system environment, it works for your purposes, it's ok. However, the only supported way is one single PHP version for both!